Symbol not found __cg_jpeg_resync_to_restart, Leopard 10.5.8

You are here

6 posts / 0 new
Last post
Symbol not found __cg_jpeg_resync_to_restart, Leopard 10.5.8

Hi All,

I get an error when launching Alfresco for the first time. It looks like Tomcat doesn't launch, but I then get an error for soffice.bin. Are they related?
Leopard 10.5.8. Latest JVM installed.

I've tried searches, but couldn't find anything handy. It looks like it's a case issue and the system uses apple's libJPEG.dylib?

PID file (/Applications/alfresco-3.4.a/tomcat/temp/catalina.pid) found. Is Tomcat still running? Start aborted.
/Applications/alfresco-3.4.a/tomcat/scripts/ctl.sh : tomcat could not be started

Error on screen:
The application soffice.bin quit unexpectedly.
Symbol not found: __cg_jpeg_resync_to_restart
Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Framework/ImageIO.framework/Versions/A/ImageIO
Expected in: /Applications/alfresco-3.4.a/common/lib/libJPEG.dylib

I tried installing it on 2 computers, both updated Leopards, and had this same issue. I'm not sure what to do now. I hope someone has had this before?

Thank you,

Re: Symbol not found __cg_jpeg_resync_to_restart, Leopard 10.5.8

Hmm... odd one. I don't think we've got anyone here still running 10.5 to test. What's the output of "java -version"?


Mike Hatfield
Engineering Manager, Client Applications
Find me on Twitter
Get the Alfresco iOS app
Get the Alfresco Android app

Re: Symbol not found __cg_jpeg_resync_to_restart, Leopard 10.5.8

Hi, this is my first contact with Alfresco and I'm getting this problem too.
I'm using MacOsX 10.6.4. Here is the diagnostic log:

Process:         soffice.bin [2285]
Path: /Applications/alfresco-3.4.a/openoffice/Contents/MacOS/soffice.bin
Identifier: soffice.bin
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: java [2275]
Date/Time: 2010-10-03 09:11:34.773 -0300
OS Version: Mac OS X 10.6.4 (10F569)
Report Version: 6
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0
Dyld Error Message:
Symbol not found: __cg_jpeg_resync_to_restart
Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
Expected in: /Applications/alfresco-3.4.a/common/lib/libJPEG.dylib
in /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib

And here is the java -version:
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02-279-10M3065)
Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01-279, mixed mode)

Re: Symbol not found __cg_jpeg_resync_to_restart, Leopard 10.5.8

some symbolic links seem to be incorrect. Solution below works for me on
Systemversion: Mac OS X 10.6.4 (10F569)
Kernel-Version: Darwin 10.4.0

delete the symlinks "libpng.dylib" and "libjpeg.dylib" in "/common/lib"

Create new symlinks to the right libs.

ln -s /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libPNG.dylib <your installation directory>/common/lib/libPNG.dylib

ln -s /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libJPEG.dylib <your installation directory>/common/lib/libJPEG.dylib


Re: Symbol not found __cg_jpeg_resync_to_restart, Leopard 10.5.8


Hi, your solution works for me too...

thanks for your help. :wink:

cheers, Cristiano

Re: Symbol not found __cg_jpeg_resync_to_restart, Leopard 10

Looks like the source of the problem is in the installer file:

forums index