Installing on LINUX Server

You are here

12 posts / 0 new
Last post
Installing on LINUX Server

Hi all.

I'm looking for the right way to install Alfresco Community edition 3.2r2 on a clean LINUX Server installation (CENTOS 5.4).
I can use only line commands. There's no required software installed (like Java, Tomcat, Mysql etc..).

I found the installer with all the required software, but it can be launched only from a GUI I've read.
Do I have to install any single required software manually if I can't use the GUI?

I'm a bit confused. Actually I have downloaded the Alfresco-Community-3.2r2-Linux-x86-Install, and launched via cmd line. It extracts some files.. but what should I do now??
Do am I wrong?


Win 7

Re: Installing on LINUX Server

The steps you'll need to take to install Alfresco on Linux depend on your setup.

Are you sitting at the linux machine you want to install Alfresco on? Or are you connecting from a remote machine?

If connecting from a remote machine is it windows, mac or linux?

Regardless you'll want to use X11 gui to install Alfresco, but how to do that will depend on your setup.

Re: Installing on LINUX Server

Are you sitting at the linux machine you want to install Alfresco on?

No. Is a dedicated server, phisically hosted by a provider.
Or are you connecting from a remote machine?

I'm connecting via ssh to manage the server.
If connecting from a remote machine is it windows, mac or linux?

Client mounts Windows.
Regardless you'll want to use X11 gui to install Alfresco, but how to do that will depend on your setup.

Maybe I can try to install a GUI on the server machine...

Win 7

Re: Installing on LINUX Server


I also need to install Alfresco only with command line.

I remember there where problems to install Alfresco Labs 3.0 with command line.

Is it possible to install Alfresco 32r2 only with command line ?

(I cannot use tools like xrdp to access the server).


Re: Installing on LINUX Server

All the installer is doing is copying files into the right place and writing a couple of config files.

You should be able to do this on a command line rather than mucking around with X11.

I suggest you become familiar with installing alfresco locally before trying to install alfresco on a remote server.

The key to look for in the installation guide is to manually install the Alfresco WAR file.

Re: Installing on LINUX Server

X11 is probably already installed on your server, type whereis xclock
or whereis xterm
if those are there you probably have x11 installed.

If you do want to try to follow the directions on the Alfresco wiki and install using X11 you'll need to download Xming (or equivalent) onto your windows machine your using to connect to the Linux server.

start Xming

Assuming you're using Putty to connect to your Linux server open putty

under connection on the left expand SSH,
select X11
check Enable X11 forwarding
in X display location type, or localhost (mine only works with the ip)

under category select Session and log into your machine as normal.

check to see that X11 and xming are all good type command
if that works you just need to copy the X11 cookie into root's files and then you can install Alfresco as the wiki describes

type into ocmmand line
$ xauth list
you'll get something like --> host.domain.org/unixXX MIT-MAGIC-COOKIE-1 3982d02d02fc320ebc92ed02a29372e3932a
now su to root and copy the cookie
$ sudo su
root$ xauth add host.domain.org/unixXX (copy here everything that xauth list showed.

now you can run the installer as root and you'll see the gui displays and everything

Re: Installing on LINUX Server

Thanks brassmachine.
On your steps I've found the starting point to install GUI on my hosted server.

This work was a bit harder than I expected, but at the end I was able to install Alfresco on CENTOS 5.4 with a GUI, cutting many manually operations.
I've followed this useful guide: http://wiki.centos.org/HowTos/VNC-Server to install the VNC environment.

Obviously, JDK (a little bit complicated for me), MySQL and OpenOffice was already installed before running the installer. I've encountered only an issue when the wizard tried to create the MySQL database.. and even if I checked the correct listening port for MySQL, I had to create an empty database manually.
Rest, run as well.

Now that I have Alfresco in place, starting Alfresco with
[root@host alfresco]# ./alfresco.sh start
I have
Using CATALINA_BASE: /usr/local/alfresco/tomcat
Using CATALINA_HOME: /usr/local/alfresco/tomcat
Using CATALINA_TMPDIR: /usr/local/alfresco/tomcat/temp
Using JRE_HOME: /usr/java/jdk1.6.0_17

..but seems that something does not goes right. Connecting on http://myhost:8080/alfresco I have: 'The requested resource () is not available.'
Apache Tomcat/6.0.18.

What should I check? I tried to manually config ALF_HOME and JAVA_HOME but without success.

Win 7

Re: Installing on LINUX Server

I notice that alf_data directory is not in place after install process. Should it?
Does installer pass some sql query to MySQL server? Cause I can only skip this step.
Also giving GRANT privileges to logged user, the installer can't create the database or anything related...

Error is 'Could not select database'. (even if database is in the input or already created)

Win 7

Re: Installing on LINUX Server


I am trying to install Enterprise Edition 3.2 on RHEL5 Server. I using the "Alfresco Enterprise Edition Detailed Install & Configure Guide.pdf" to follow instructions.

My system already has MySQL 5.0.77, which is supported by this version. The guide above contains the section "Configuring MySQL" which it's focused for a Windows-based installation.

Obviously, mysql is not setup yet, since "mysql -u root -p" returns an error indicating it cannot connect though the socket.

Since the instructions above in the guide do not apply for my system, where can I find the instructions for my installation type?

Thanks, Ricardo

Re: Installing on LINUX Server


Are you sure that Mysql is running ?

su -
service mysqld status

if not...

su -
service mysqld start

Good luck :-)

Re: Installing on LINUX Server

I've never installed alfresco using gui as I've no gui, no offenoffice, no imagemagick on the servers. Just download war file and read installation guide
But if have no experience with java/tomcat it can be more difficult to solve the problems you may face

Re: Installing on LINUX Server

Thanks dranakan.

I was under the impresion the mysqld service was already running. Anyway, that took care of it.

Now, I have a concern. Maybe it's nothing to worry about, but I'd like to be on the safe side.

When the MySQL system tables were being installed, a warning message came up:
option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295

Is that something I should worry about? Researched it on mysql.com but found nothing would tell me not to worry.

Thanks, Ricardo

forums index