Installer hangs at 32 percent

You are here

8 posts / 0 new
Last post
Installer hangs at 32 percent

Hi, I'm just trying to install 4.2c CE on Centos 6.3 x64. This is a fresh installation of Centos, and I'm using the GUI installer.

The installer starts fine, but whatever I do, it hangs at 32%, specifically at this point;

creating link <install dir>/postgresql/bin/postmaster

I've tried the following;

Installing to a different folder (used the default /opt and a /data mount)
Tried Easy and Advanced install options
Tried running the installer with Postgresql already installed, and with it not installed (I understand the Advanced installation option expects Postgresql to already be installed).
Tried the GUI and text based installers.

I'm running the installer as 'root', so have full rights to the system. I've tried every combination I can think of to install this, but it fails each time at exactly the same point.

Does anyone have any ideas?


Hi tman247,

Hi tman247,
There may be case when ports are conflicts. Do full uninstall alfresco and try vanilla may help. Also do check have you downloaded proper package and running 32-bit or 64-bit installer on respected environment?

Ghanshyam Rathod
<< If this post was helpful, please click "mark comment as useful" >>


Thanks. I'm actually installing this in a VM (ESXi), and am using snapshots to roll back when I'm trying to get the install working, so when it fails, I just revert, and it's as though Alfresco was never there. This is as clean a start as you can get.

Anyway, I'm def using the 64-bit installer on 64-bit CentOS, so it's baffling as to why this is happening.



Ghanshyam Rathod
<< If this post was helpful, please click "mark comment as useful" >>

Your postgresql is running

Your OS postgresql may be running,can u please check on this

Joseph John


Ok, I took the decision to do a completely fresh install of Centos 6.3 x64 from the original source media (not our kickstart build). Once built, I started the CE installer, and waited. It got to 32% (again!), and then paused for 1-2 minutes, then I saw the new message 'Waiting for Postmaster', and the installer continued! Yay, I'm getting somewhere. So, now I wait for the install to complete. Another lengthy pause at 100%, but then a success message.

All the services then seem to start ok, and it all looks good. I then connect to the web page (http://localhost:8080/share), and try and logon as admin/admin, but it says 'The remote server may be unavailable or your authentication details have not been recognized.'

Is this the right page or credentials for the initial logon? Pretty basic stuff I know, but I don't want to come to a halt now.


Ok, I'm logged in now. Everything seems ok from what I can tell so far. Very, very odd install problem though.

I had hit the exact same

I had hit the exact same problem on my 64 bit Arch Linux today during a fresh install of 4.2.c. The solution appearently was to run the installer as root and wait for a couple of minutes (doing so with my plain user did not help).

Hope that helps hunting down this issue.. it's quite scary as a first-time Alfresco experience for a newcomer ;)

forums index