HTTP Status 404 when trying to access /share

You are here

6 posts / 0 new
Last post
HTTP Status 404 when trying to access /share

Hello everyone, I am knew to Alfresco and this forum and I would like some assitance with my issue. I have set up Alfresco 5.0.a today on a CentOS 6.5 computer with Apache version 2.2, Mysql version 5.1.73, OpenJDK 1.7 (Open source java 1.7), Tomcat 7.0.53 using these two sites as a reference http://www.jangestre.com/2012/10/install-alfresco-4-on-centos-5-using.html docs.alfresco.com/community/tasks/simpleinstall-community-lin.html The only thing that got installed by the Alfresco installer was Tomcat and Java, however I had previously installed Java (I believe I needed it for the mysql java connector) from the CentOS repository but told the Alfresco installer to install Java anyway (incase Alfresco needs a particular version). After Installation I hit yes to launch alfersco and I tried accessing and and I am greeted with this

"HTTP Status 404 - /share

type Status report

message /share

description The requested resource is not available.
Apache Tomcat/7.0.53"

If I just visit I am greted with the Apache/Tomcat page, but if I click on anything I get the same HTTP Status 404 error. The issue has nothing to do with the firewall or SELinux as I have tried disabling both and this page still shows up, I assume its something with Tomcat, maybe with permissions, any ideas? Thank you guys and I hope to be able to use Alfresco in the future!

alfresco.log http://pastebin.com/i39xKJJL
catalina.out http://pastebin.com/w3nGjbEX

If you need more logs/information, please just ask, I want to get this working

Just a thought, the user you

Just a thought, the user you are using to connect to the database with - does it have permissions to change the schema of the database?

I gave the user full

I gave the user full privileges so that would be yes? How else can I check? The command I did was

GRANT ALL PRIVILEGES ON alfresco.* TO alfresco@localhost IDENTIFIED BY 'password';

Well from the logs it shows

Well from the logs it shows that it's failing to get the server IP address. Your FQDN that you have listed in the logs. Are you able to ping to it?

Have you tried...

to see if that would work?

Well I removed the virtual

Well I removed the virtual machine and re-did everything on a new fresh install of CentOS on another virtual machine, I followed the same install steps as I did before, but my hostname and domain name are different now. I tried what you told me to (replacing with my new hostname/domain name) and it just keeps loading infinitely.

EDIT: I restarted the computer and now I get the same 404 error.

I have uninstalled alfresco

I have uninstalled alfresco and reinstalled it to see if anything changed and when I typed "" it brought me to "" where I am greeted to login so it looks like ive gotten somewhere. If I type I am greeted with the tomcat page and I still get 404 errors when clicking some things. I am assuming this is normal because maybe alfresco does not install these pages in tomcat.

forums index