Mapping Network driver problem

You are here

7 posts / 0 new
Last post
Mapping Network driver problem

On Windows 2003, installed Alfresco 2.1 Enterprise.

Suppose the machine name is myserver.
At NetworkPlace-->Microsoft Windows Network->Workgroup, there is another new server name: myservera.

Then on another client machine Windows XP, I can run webclient to access Afresco.
Then try to map network driver for Alfresco user Joe:

\\myservera\Alfresco\Joe Blogs --> Y:

then windows XP ask for user name and password for connection.

Alfresco user Joe's user name and password
Windows 2003 Administrator user name and password

Both of them are refused.

How to solve this issue?

CIFS Problem


At the your_tomcat_path\webapps\alfresco\WEB-INF\classes\alfresco, you will find file-servers.xml:

In the line 5 you will find:

That means that if you want to use the CIFS, you must connect to \\your_alfresco_server_A\alfresco.

use your alfresco user and password to access the share drive.

I hope this can help you.


same problem

I am having the same problem. I can't map a network drive, doing what is suggested in the Getting Started guide. I even changed the line in the file-servers.xml file to , as suggested in the installation guide. I am on WinXP running the Enterprise trial version. Any ideas? I can provide more info if needed. Thanks!

Oh, and the web interface works just fine on http://localhost:8080.


CIFS Problem


Try changing "${localname}_A" with your name machine. If your machine is called orion change then change in the file-servers.xml "${localname}_A" with "orion_A".

You have DNS in your LAN or do you have the host file configured.

Another tip, you must change the in the WINS configuration of your NIC to use NETBIOS over TCP/IP

Try this..

Nope, didn't work with the suggested changes. It still doesn't accept any login, just keeps popping up the dialog box again.

One thing I thought of that could be an issue is the length of the name of the machine on the network. My machine is called "ocean-schiller", but it is on the ocean.local domain, so the full network name is ocean-schiller.ocean.local. When I check nbtstat -n, I get:
NetBIOS Local Name Table

Name Type Status
OCEAN <00> GROUP Registered

And when viewing the network tree in windows explorer, I see my machine as "ocean-schiller" and "ocean-schiller_".

So when the _A suffix is appended to my machine name, could there be an issue with the length of the name, so that the "A" doesn't get added, only the "_"? The full network name is 26 characters.

A possibly related question- should I be trying to connect to \alfresco\Users\Joe Bloggs, or just \alfresco or something else?

Please advise. Thank you!

In a weird turn of events, when I browse in windows explorer to \\ocean-schiller_\alfresco\, I am able to log in (I only tried as admin, not Joe Bloggs) and see the files. Hmmm....

Well, after correctly seeing it in explorer, I was able map the network drive. What gives? :-P

forums index