Home

Cifs - Wrong Root Directory

You are here

4 posts / 0 new
Last post
Cifs - Wrong Root Directory

Hello,

I am currently trying to setup the trial of Alfresco Enterprise in my domain on a Windows 8 r2 server with Windows 7 Clients. Following the documentation I managed to map the repository to a network drive, however, the network drives root directory is not the root of the repository but the premade folder "Sites".
If logged in as "admin" I can freely manage the folder, yet I have no idea how to change the root of the network drive to the actual root. I would be very grateful for any input on what to change for me to be able to map the normal access to the repository's root.
If you need any more information on the hardware setup feel free to ask.

Thanks in advance,
Florian

Re: Cifs - Wrong Root Directory

protocols.rootPath=/${spaces.company_home.childname}

Senior Software Engineer
Alfresco

Re: Cifs - Wrong Root Directory

Hello again,

first: Thanks for your help, this was already included in the global properties tho. I tried to change it to "protocols.rootPath=/${spaces.company_home.childname}/${spaces.sites.childname", which I found in another topic, however, this did not help either.

I will attach a copy of my global properties for your convenience.

Thanks for your help,
Florian

###############################
## Common Alfresco Properties #
## Enterprise overlay         #
###############################
 
dir.root=C:/Alfresco/alf_data
 
alfresco.context=alfresco
alfresco.host=xxx.xxx.xxx.xxx
alfresco.port=8080
alfresco.protocol=http
 
share.context=share
share.host=xxx.xxx.xxx.xxx
share.port=8080
share.protocol=http
 
### database connection properties ###
db.driver=org.postgresql.Driver
db.username=alfresco
db.password=********
db.name=alfresco
db.url=jdbc:postgresql://localhost:5432/${db.name}
 
### FTP Server Configuration ###
ftp.enabled=true
ftp.port=21
ftp.ipv6.enabled=false
 
### RMI service ports ###
alfresco.rmi.services.port=50500
avm.rmi.service.port=0
avmsync.rmi.service.port=0
attribute.rmi.service.port=0
authentication.rmi.service.port=0
repo.rmi.service.port=0
action.rmi.service.port=0
deployment.rmi.service.port=0
 
### External executable locations ###
ooo.exe=C:/Alfresco/openoffice/App/openoffice/program/soffice.exe
ooo.enabled=false
ooo.port=8100
img.root=C:/Alfresco/imagemagick
img.dyn=${img.root}/lib
img.exe=${img.root}/convert
swf.exe=C:/Alfresco/swftools/pdf2swf.exe
jodconverter.enabled=true
jodconverter.officeHome=C:/Alfresco/openoffice/App/openoffice
jodconverter.portNumbers=8100
 
### Initial admin password ###
alfresco_user_store.adminpassword=22d3b0b61e334d41f077eeec4f3e41b6
 
### E-mail site invitation setting ###
notification.email.siteinvite=false
 
### File Protocol Root ###
protocols.rootPath=/${spaces.company_home.childname}
 
### License location ###
dir.license.external=C:/Alfresco
 
### Solr indexing ###
index.subsystem.name=solr
dir.keystore=${dir.root}/keystore
solr.port.ssl=8443
 
### BPM Engine ###
system.workflow.engine.jbpm.enabled=false
 
### Replication ###
replication.enabled=true

Re: Cifs - Wrong Root Directory

what's your mean of "actual root".

by setting protocols.rootPath=/${spaces.company_home.childname} in \Alfresco\tomcat\shared\classes\alfresco-global.properties
and restart alfresco service

When you login, cifs root path is /Company Home which contains
Data Dictionary
Guset Home
Sites
User Home
and three alfreco files.

hope be useful.