Home

CIFS 3.2 - Can't map drive Windows 7 but ftp works

You are here

2 posts / 0 new
Last post
CIFS 3.2 - Can't map drive Windows 7 but ftp works

I have 3.2 installed on a Debian 5.3 server. It seems to function perfectly except for one issue. I am unable to use CIFS to map a network drive on a Windows workstation in the same workgroup. FTP works fine. I've turned the firewall off on the server. I am able to find the server name and path in Alfresco Explorer (\\ALF\Alfresco), but when I enter it into the windows workstation, it constantly returns "The Network Name can not be found". I can ping the server, and as I mentioned, the ftp part of the alfresco file-server works just fine.

Here's my /opt/Alfresco/tomcat/webapps/alfresco/WEB-INF/classes/alfresco/subsystems/fileServers/default/file-server.properties:

filesystem.name=Alfresco
filesystem.acl.global.defaultAccessLevel=
 
cifs.enabled=true
cifs.serverName=alf
cifs.domain=789
cifs.broadcast=255.255.255.0
# An empty value indicates bind to all available network adapters
cifs.bindto=10.1.10.195
cifs.ipv6.enabled=false
cifs.hostannounce=true
# Enable the use of asynchronous sockets/NIO code
cifs.disableNIO=false
# Disable the use of JNI code. Only currently affects Windows
cifs.disableNativeCode=false
# Session timeout, in seconds. Defaults to 15 minutes, to match the default Windows client setting.
# If no I/O is received within that time the session is closed by the server
cifs.sessionTimeout=900
 
# Can be mapped to non-privileged ports, then use firewall rules to forward requests from the standard ports
cifs.tcpipSMB.port=445
cifs.netBIOSSMB.sessionPort=139
cifs.netBIOSSMB.namePort=137
cifs.netBIOSSMB.datagramPort=138
 
# Optional WINS server primary and secondary IP addresses. Ignored if autoDetectEnabled=true
cifs.WINS.autoDetectEnabled=true
cifs.WINS.primary=1.2.3.4
cifs.WINS.secondary=5.6.7.8
 
ftp.enabled=true
ftp.port=21
ftp.ipv6.enabled=false
 
nfs.enabled=false
 
cifs.urlfile.prefix=http://my.domain.com:8080/alfresco/

And here's my /opt/Alfresco/tomcat/webapps/alfresco/WEB-INF/classes/alfresco/file-server.properties

filesystem.name=Alfresco
 
cifs.enabled=true
cifs.localname=alf
cifs.domain=789
cifs.broadcast=255.255.255.0
cifs.bindto=10.1.10.195
cifs.ipv6=disabled
cifs.hostannounce=true
 
ftp.enabled=true
ftp.ipv6=disabled
 
nfs.enabled=false

I've confirmed the workstations are in the same workgroup. Alfresco Explorer shows \\ALF\Alfresco\ as the network path for "Company Home". But it doesn't work. I don't know what else to check. There are no errors or warnings in the alfresco.log. It just shows a normal startup. Anyone aware of problems with CIFS and Windows 7?

HELP! :D

Re: CIFS 3.2 - Can't map drive Windows 7 but ftp works

I had a similar issue on Vista. I was able to fix it using a comment to this bug report.